Sitecore App Center Login Fails

I tried logging into Sitecore’s App Center, and got the following error:

The credentials used to log in to the Sitecore App Center cannot access the license used on this server

Weird.

This was in Chrome. Strangely, I discovered that I could log in through Chrome Canary. What’s different?

Well, being privacy conscious, I know that I’ve blocked Third-Party Cookies in Chrome. I didn’t think I’d done that in Canary. Looking in Canary DevTools:

Oh look, Third Party Cookies. If I turn OFF this setting (and this is it ON in Chrome)…

… then suddenly I could log-in in Chrome.

This is a bit of a problem. There are some scenarios where users won’t be able to login to App center:

  • Some users (like me) turn on Third Party Cookie blocking for privacy.
  • Firefox blocks Third Party Cookies in “Private Mode”
  • Chrome blocks Third Party Cookies in Incognito mode.
  • Firefox is disabling Third Party Cookies for new Users – though this may be only known tracking cookies.
  • Safari had blocked Third Party Cookies by default in 2017. Now, I’m not sure what the behaviour under ITP2.2 is.

In short, Third Party cookies are slowly going away, which might be a bit of a problem for the App Center login…

Advertisements
Sitecore App Center Login Fails

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.